<!DOCTYPE html><html lang="en-US"><head ><meta charset="UTF-8" /><link type="text/css" media="all" href="http://7ray83atccc27v79a3d2diz1.wpengine.netdna-cdn.com/wp-content/cache/autoptimize/css/autoptimize_22ae0cf4c1805c805521614c0d4f85ad.css" rel="stylesheet" /><title>Sweep, sweep, BROOM – Rochester, MN</title><meta name="viewport" content="width=device-width, initial-scale=1" /><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Rochester, MN &raquo; Feed" href="http://rochestermn.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Rochester, MN &raquo; Comments Feed" href="http://rochestermn.com/comments/feed/" /><link rel="canonical" href="http://rochestermn.com/entertainment/sweep-sweep-broom/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/rochestermn.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.2"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='dashicons-css'  href='http://rochestermn.com/wp-includes/css/dashicons.min.css?ver=4.6.2' type='text/css' media='all' /><link rel='stylesheet' id='daily-dish-google-fonts-css'  href='//fonts.googleapis.com/css?family=Alice%7CLato%3A400%2C700%2C900&#038;ver=1.0.2' type='text/css' media='all' /><!--[if lt IE 9]> <script type='text/javascript' src='http://rochestermn.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script> <![endif]--><link rel='https://api.w.org/' href='http://rochestermn.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://rochestermn.com/xmlrpc.php?rsd" /><link rel="alternate" type="application/json+oembed" href="http://rochestermn.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Frochestermn.com%2Fentertainment%2Fsweep-sweep-broom%2F" /><link rel="alternate" type="text/xml+oembed" href="http://rochestermn.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Frochestermn.com%2Fentertainment%2Fsweep-sweep-broom%2F&#038;format=xml" /><link rel='dns-prefetch' href='//v0.wordpress.com'><link rel="icon" href="http://rochestermn.com/wp-content/themes/daily-dish-pro/images/favicon.ico" /><link rel="pingback" href="http://rochestermn.com/xmlrpc.php" /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-285548-1', 'auto');
  ga('send', 'pageview');</script><meta name="google-site-verification" content="pNgIFvicBwZst64x70HxUVeoUDDdEJQfNBHA49tuPa4" />  <script type='text/javascript'>var gptadslots=[];
	var googletag = googletag || {};
	googletag.cmd = googletag.cmd || [];
	(function(){ var gads = document.createElement('script');
		gads.async = true; gads.type = 'text/javascript';
		var useSSL = 'https:' == document.location.protocol;
		gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
		var node = document.getElementsByTagName('script')[0];
		node.parentNode.insertBefore(gads, node);
	})();</script> <script type="text/javascript">googletag.cmd.push(function() {

		//Adslot 1 declaration
		gptadslots[1]= googletag.defineSlot('/132916964/postbulletin.com/rochestermn', [[300,600]],'div-gpt-ad-890845547766019142-1').setTargeting('pos',['atf']).addService(googletag.pubads());

		//Adslot 2 declaration
		gptadslots[2]= googletag.defineSlot('/132916964/postbulletin.com/rochestermn', [[300,250]],'div-gpt-ad-890845547766019142-2').setTargeting('pos',['atf']).addService(googletag.pubads());

		//Adslot 3 declaration
		gptadslots[3]= googletag.defineSlot('/132916964/postbulletin.com/rochestermn', [[728,90]],'div-gpt-ad-890845547766019142-3').addService(googletag.pubads());

		googletag.pubads().enableSingleRequest();
		googletag.pubads().enableAsyncRendering();
		googletag.enableServices();
	});</script> <meta property="og:type" content="article" /><meta property="og:title" content="Sweep, sweep, BROOM" /><meta property="og:url" content="http://rochestermn.com/entertainment/sweep-sweep-broom/" /><meta property="og:description" content="Broomball is the wave for wintertime fun." /><meta property="article:published_time" content="2017-01-20T20:08:22+00:00" /><meta property="article:modified_time" content="2017-01-20T20:08:22+00:00" /><meta property="og:site_name" content="Rochester, MN" /><meta property="og:image" content="http://rochestermn.com/wp-content/uploads/2017/01/broomballs_WEB.jpg" /><meta property="og:image:width" content="740" /><meta property="og:image:height" content="420" /><meta property="og:locale" content="en_US" /><meta name="twitter:image" content="http://rochestermn.com/wp-content/uploads/2017/01/broomballs_WEB.jpg?w=640" /><meta name="twitter:card" content="summary_large_image" /></head><body class="single single-post postid-24965 single-format-standard custom-background browser-unknown aesop-core aesop-on-daily-dish-pro-theme custom-header header-full-width full-width-content et_divi_builder" itemscope itemtype="http://schema.org/WebPage"><div class="site-container"><nav class="nav-secondary" itemscope itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-global-navigation" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-1966" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-has-children menu-item-1966"><a href="http://rochestermn.com/magazine/radishmagazine/" itemprop="url"><span itemprop="name">Radish Magazine</span></a><ul class="sub-menu"><li id="menu-item-4486" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4486"><a href="http://rochestermn.com/magazine/outdoor/" itemprop="url"><span itemprop="name">Outdoor</span></a></li><li id="menu-item-4484" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4484"><a href="http://rochestermn.com/magazine/green-living/" itemprop="url"><span itemprop="name">Green living</span></a></li><li id="menu-item-4483" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4483"><a href="http://rochestermn.com/magazine/gardening/" itemprop="url"><span itemprop="name">Gardening</span></a></li><li id="menu-item-4485" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4485"><a href="http://rochestermn.com/magazine/health/" itemprop="url"><span itemprop="name">Health</span></a></li><li id="menu-item-4482" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4482"><a href="http://rochestermn.com/magazine/eating-well/" itemprop="url"><span itemprop="name">Eating well</span></a></li></ul></li><li id="menu-item-4472" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-has-children menu-item-4472"><a href="http://rochestermn.com/magazine/at-home-magazine/" itemprop="url"><span itemprop="name">At Home Magazine</span></a><ul class="sub-menu"><li id="menu-item-4480" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4480"><a href="http://rochestermn.com/magazine/buy-build-remodel/" itemprop="url"><span itemprop="name">Buy, build, remodel</span></a></li><li id="menu-item-4479" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4479"><a href="http://rochestermn.com/magazine/trend-try/" itemprop="url"><span itemprop="name">Trends to try</span></a></li><li id="menu-item-4481" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4481"><a href="http://rochestermn.com/magazine/splurge-save/" itemprop="url"><span itemprop="name">Splurge vs. Save</span></a></li><li id="menu-item-4478" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4478"><a href="http://rochestermn.com/magazine/home-decor/" itemprop="url"><span itemprop="name">Home decor</span></a></li></ul></li><li id="menu-item-1965" class="menu-item menu-item-type-taxonomy menu-item-object-magazine current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-1965"><a href="http://rochestermn.com/magazine/pb507/" itemprop="url"><span itemprop="name">507 Magazine</span></a><ul class="sub-menu"><li id="menu-item-4536" class="menu-item menu-item-type-taxonomy menu-item-object-magazine current-post-ancestor current-menu-parent current-post-parent menu-item-4536"><a href="http://rochestermn.com/magazine/arts-entertainment/" itemprop="url"><span itemprop="name">Arts and Entertainment</span></a></li><li id="menu-item-4537" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4537"><a href="http://rochestermn.com/magazine/drinks-dining/" itemprop="url"><span itemprop="name">Drinks and Dining</span></a></li><li id="menu-item-4538" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4538"><a href="http://rochestermn.com/magazine/movies/" itemprop="url"><span itemprop="name">Movies</span></a></li><li id="menu-item-4539" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4539"><a href="http://rochestermn.com/magazine/music-theater/" itemprop="url"><span itemprop="name">Music and Theater</span></a></li><li id="menu-item-21388" class="menu-item menu-item-type-taxonomy menu-item-object-magazine current-post-ancestor current-menu-parent current-post-parent menu-item-21388"><a href="http://rochestermn.com/magazine/recreation/" itemprop="url"><span itemprop="name">Recreation</span></a></li></ul></li><li id="menu-item-1967" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-has-children menu-item-1967"><a href="http://rochestermn.com/magazine/rochestermagazine/" itemprop="url"><span itemprop="name">Rochester Magazine</span></a><ul class="sub-menu"><li id="menu-item-4541" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4541"><a href="http://rochestermn.com/magazine/columns/" itemprop="url"><span itemprop="name">Columns</span></a></li><li id="menu-item-4542" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4542"><a href="http://rochestermn.com/magazine/feature-stories/" itemprop="url"><span itemprop="name">Feature Stories</span></a></li><li id="menu-item-4543" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-4543"><a href="http://rochestermn.com/magazine/events/" itemprop="url"><span itemprop="name">Events</span></a></li></ul></li><li id="menu-item-3409" class="menu-item menu-item-type-taxonomy menu-item-object-magazine menu-item-3409"><a href="http://rochestermn.com/magazine/local-list/" itemprop="url"><span itemprop="name">Local List</span></a></li><li id="menu-item-4456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4456"><a href="http://marketing.postbulletin.com/print-advertising" itemprop="url"><span itemprop="name">Advertise</span></a></li><li id="menu-item-4457" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4457"><a href="http://rochester.iserviceswebserver.com/" itemprop="url"><span itemprop="name">Subscribe</span></a></li></ul></div></nav><header class="site-header" itemscope itemtype="http://schema.org/WPHeader"><div class="wrap"><div class="title-area"><h1 class="site-title" itemprop="headline"><a href="http://rochestermn.com/">Rochester, MN</a></h1><h2 class="site-description" itemprop="description">Your guide to living local</h2></div></div></header><nav class="nav-primary" itemscope itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-main-nav" class="menu genesis-nav-menu menu-primary"><li id="menu-item-21483" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21483"><a href="http://rochestermn.com/category/featured/" itemprop="url"><span itemprop="name">Featured</span></a></li><li id="menu-item-28" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-28"><a href="http://rochestermn.com/category/entertainment/" itemprop="url"><span itemprop="name">Entertainment</span></a></li><li id="menu-item-29" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29"><a href="http://rochestermn.com/category/lifestyle/" itemprop="url"><span itemprop="name">Lifestyle</span></a></li><li id="menu-item-30" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-30"><a href="http://rochestermn.com/category/health-wellness/" itemprop="url"><span itemprop="name">Health &#038; Wellness</span></a></li><li id="menu-item-31" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-31"><a href="http://rochestermn.com/category/food-drink/" itemprop="url"><span itemprop="name">Food &#038; Drink</span></a></li><li id="menu-item-39" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-39"><a href="http://rochestermn.com/category/outdoors/" itemprop="url"><span itemprop="name">Outdoors</span></a></li><li id="menu-item-4453" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4453"><a href="http://events.rochestermn.com" itemprop="url"><span itemprop="name">Events</span></a><ul class="sub-menu"><li id="menu-item-21207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21207"><a href="http://events.rochestermn.com/event/create" itemprop="url"><span itemprop="name">Add an Event</span></a></li></ul></li></ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-24965 post type-post status-publish format-standard has-post-thumbnail category-entertainment magazine-pb507 magazine-arts-entertainment magazine-recreation entry" itemscope itemtype="http://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Sweep, sweep, BROOM</h1><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2017-01-20T14:08:22+00:00">January 20, 2017</time> By <span class="entry-author" itemprop="author" itemscope itemtype="http://schema.org/Person"><a href="http://rochestermn.com/author/john-sievers/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">John Sievers</span></a></span></p></header><div class="entry-content" itemprop="text"><p class="p1"><span class="s1"><img class="size-medium wp-image-24967 alignleft" src="http://rochestermn.com/wp-content/uploads/2017/01/01-10-nate-rabe-chuck-krom-sj-300x226.jpg" alt="Nate Rabe is first to the loose ball pressured by Chuck Krom during a broomball game between 63 Club and Sloppy Seconds Tuesday January 10, 2017 at the Withers Sports Complex in Rochester, Minn." width="300" height="226" srcset="http://rochestermn.com/wp-content/uploads/2017/01/01-10-nate-rabe-chuck-krom-sj-300x226.jpg 300w, http://rochestermn.com/wp-content/uploads/2017/01/01-10-nate-rabe-chuck-krom-sj-768x578.jpg 768w, http://rochestermn.com/wp-content/uploads/2017/01/01-10-nate-rabe-chuck-krom-sj-1024x771.jpg 1024w, http://rochestermn.com/wp-content/uploads/2017/01/01-10-nate-rabe-chuck-krom-sj-1250x941.jpg 1250w, http://rochestermn.com/wp-content/uploads/2017/01/01-10-nate-rabe-chuck-krom-sj-400x301.jpg 400w" sizes="(max-width: 300px) 100vw, 300px" />S</span><span class="s1">loppy Waffles, Booty Wop, Flying Carp, and Whiskey Sticks are all names of local broomball teams, but surprisingly the sport is “swept” under the rug. A game with team names like this must be exciting, right?</span></p><p class="p3"><span class="s1">Some names, like Booty Wop, might be references to what happens to broomball players on the ice as they slide on spongy-soled shoes with an occasional butt-first spill.</span></p><p class="p3"><span class="s1"><img class="size-medium wp-image-24966 alignright" src="http://rochestermn.com/wp-content/uploads/2017/01/01-10-chad-zahn-tony-hart-sj-258x300.jpg" alt="Tony Hart takes a drop pass from Chad Zahn during a broomball game between 63 Club and Sloppy Seconds Tuesday January 10, 2017 at the Withers Sports Complex in Rochester, Minn." width="258" height="300" srcset="http://rochestermn.com/wp-content/uploads/2017/01/01-10-chad-zahn-tony-hart-sj-258x300.jpg 258w, http://rochestermn.com/wp-content/uploads/2017/01/01-10-chad-zahn-tony-hart-sj-768x894.jpg 768w, http://rochestermn.com/wp-content/uploads/2017/01/01-10-chad-zahn-tony-hart-sj-880x1024.jpg 880w, http://rochestermn.com/wp-content/uploads/2017/01/01-10-chad-zahn-tony-hart-sj-1250x1455.jpg 1250w, http://rochestermn.com/wp-content/uploads/2017/01/01-10-chad-zahn-tony-hart-sj-400x465.jpg 400w" sizes="(max-width: 258px) 100vw, 258px" />“[Broomball] has a bit of a reputation for being just a little odd,” says broomballer Christopher Roberts. </span></p><p class="p3"><span class="s1">You might be wondering what broomball is. </span></p><p class="p3"><span class="s1">“Broomball is played basically like a mix of hockey and indoor soccer &#8211; things like offsides and icing carry over from these games. You play with a small soccer ball and can use the stick [a specialized stick which ends in a modified rubber “broom”] or your feet to move it around and toward the goal. There are six players on the ice from each team &#8211; a goalie, two defensive, and three offensive. Each game is about an hour &#8211; technically two 24 minute halves with a halftime break in between,” explains Roberts.</span></p><div class='code-block code-block-3' style='text-align: center; margin: 8px auto;'><script type="text/javascript" src="https://www.civicscience.com/widget/jspoll/?elt=civsci-766354453&tgtid=0c28f190-9451-1a54-899a-44b7924325d4"></script><div id="civsci-766354453" class="post-content"></div></div><p class="p3"><span class="s1"><img class="alignleft size-medium wp-image-24968" src="http://rochestermn.com/wp-content/uploads/2017/01/IMG_6953-300x225.jpg" alt="IMG_6953" width="300" height="225" srcset="http://rochestermn.com/wp-content/uploads/2017/01/IMG_6953-300x225.jpg 300w, http://rochestermn.com/wp-content/uploads/2017/01/IMG_6953-400x300.jpg 400w, http://rochestermn.com/wp-content/uploads/2017/01/IMG_6953.jpg 640w" sizes="(max-width: 300px) 100vw, 300px" />Roberts has played broomball for five years and currently plays for the Struggletown Spartans, part of the Rochester Parks &amp; Recreation’s (RP&amp;R) winter league. Ben Boldt, the Recreation Supervisor for RP&amp;R, organizes the league. This year there are 16 teams with about 240 players.</span></p><p class="p3"><span class="s1">RP&amp;R installs outdoor rinks in late fall, floods them throughout the winter months, handles team registrations, produces schedules, and updates scores and standings throughout broomball season. Games take place at the outdoor Withers Sports Complex, 2021 Mayowood Road SW, which houses two rinks, on Tuesday and Thursday nights.</span></p><p class="p3"><span class="s1">Rochester’s broomballers are a wide-ranging group including casual and dedicated players. Lindsey Hanenberger has been playing around four games a year for the past six years at events like the Camp Victory Staff Reunion game, but Nathan Rabe plays on several teams and even travels for the sport.</span></p><p class="p3"><span class="s1">Rabe, a 17-year veteran, plays for the Rochester United and Cold Chalupas teams. He travels regionally for tournaments and has even played in international locations like Vancouver, BC.</span></p><p class="p3"><span class="s1">Comparing broomball to hockey, Rabe says, “it takes a lot less skill and money to get started. Anybody can play, and with a little dedication, anybody can become good at the sport.” </span></p><p class="p3"><span class="s1">“It’s not quite as fast-paced as…hockey, but it still can bring a lot of the same intensity,” claims Roberts.<span class="Apple-converted-space">   </span></span></p><p class="p3"><span class="s1">He points out that the sport includes a considerable amount of contact: “You’ll definitely fall on the ice, hit the wall, or bump up against another player.” </span></p><p class="p3"><span class="s1">Gary Dahl, who began playing broomball as a junior high student, remembers having his nose broken by a flying broomstick: “I saw the stick flying through the air in slow motion at me, but there was just no time to get out of the way.”</span></p><p class="p3"><span class="s1">Standing rink-side, on a dark, bitterly cold, wind-scoured Tuesday night, with three or four spectators watching from a heated car, it’s clear broomball is played not for glory, but for love of the game.<span class="Apple-converted-space">   </span></span></p><p class="p3">Try to join a pick-up game at Rochester’s Graham Arena from 11:30 a.m.-1:30 p.m. on Fridays.</p><div class="mceTemp"></div><p class="p3"><div class='code-block code-block-2 ai-viewport-2' style='text-align: center; margin: 8px auto;'> <span class="hs-cta-wrapper" id="hs-cta-wrapper-77f07dc0-2c39-4ca4-9eac-90580c2f7c55"> <span class="hs-cta-node hs-cta-77f07dc0-2c39-4ca4-9eac-90580c2f7c55" id="hs-cta-77f07dc0-2c39-4ca4-9eac-90580c2f7c55"> <!--[if lte IE 8]><div id="hs-cta-ie-element"></div><![endif]--> <a href="http://cta-redirect.hubspot.com/cta/redirect/541983/77f07dc0-2c39-4ca4-9eac-90580c2f7c55" ><img class="hs-cta-img" id="hs-cta-img-77f07dc0-2c39-4ca4-9eac-90580c2f7c55" style="border-width:0px;" src="https://no-cache.hubspot.com/cta/default/541983/77f07dc0-2c39-4ca4-9eac-90580c2f7c55.png"  alt="Rochester Market Data Free Download"/></a> </span> <script charset="utf-8" src="https://js.hscta.net/cta/current.js"></script> <script type="text/javascript">hbspt.cta.load(541983, '77f07dc0-2c39-4ca4-9eac-90580c2f7c55', {});</script> </span></div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="http://rochestermn.com/category/entertainment/" rel="category tag">Entertainment</a></span></p></footer></article><div class="after-entry widget-area"><section id="text-29" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"></div></div></section></div></main></div></div><footer class="site-footer" itemscope itemtype="http://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2017 &middot; <a href="http://www.postbulletin.com" > The Post-Bulletin </a>&middot<a href="http://rochestermn.com/about/"> About RochesterMN</p></div></footer></div> <script type="text/javascript">(function(d,s,i,r) {
      if (d.getElementById(i)){return;}
      var n=d.createElement(s),e=d.getElementsByTagName(s)[0];
      n.id=i;n.src='//js.hs-analytics.net/analytics/'+(Math.ceil(new Date()/r)*r)+'/541983.js';
      e.parentNode.insertBefore(n, e);
    })(document,"script","hs-analytics",300000);</script>  <script type="text/javascript">var ssaUrl = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'centro.pixel.ad/iap/e5fec53480dccce4';new Image().src = ssaUrl;</script>  <script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201703'></script> <script type='text/javascript'>/*  */
var su_magnific_popup = {"close":"Close (Esc)","loading":"Loading...","prev":"Previous (Left arrow key)","next":"Next (Right arrow key)","counter":"%curr% of %total%","error":"Failed to load this link. <a href=\"%url%\" target=\"_blank\"><u>Open link<\/u><\/a>."};
/*  */</script> <script type='text/javascript'>/*  */
var et_pb_custom = {"ajaxurl":"http:\/\/rochestermn.com\/wp-admin\/admin-ajax.php","images_uri":"http:\/\/rochestermn.com\/wp-content\/themes\/genesis\/images","builder_images_uri":"http:\/\/rochestermn.com\/wp-content\/plugins\/divi-builder\/includes\/builder\/images","et_frontend_nonce":"884aea11ad","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"c39b420525","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","is_builder_plugin_used":"1","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"24965","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":""};
/*  */</script> <script type='text/javascript' src='http://stats.wp.com/e-201703.js' async defer></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.4.2',blog:'100411598',post:'24965',tz:'-6',srv:'rochestermn.com'} ]);
	_stq.push([ 'clickTrackerInit', '100411598', '24965' ]);</script> <script type="text/javascript" defer src="http://7ray83atccc27v79a3d2diz1.wpengine.netdna-cdn.com/wp-content/cache/autoptimize/js/autoptimize_49b9df98867b528879b2e60691c43e36.js"></script></body></html>